Magento 2.0.18 is the final 2.0.x release. After March 2018, Magento 2.0.x will no longer receive security patches, quality fixes, or documentation updates.
To maintain your site's performance, security, and PCI compliance, upgrade to the latest version of Magento.

What is the software that the Magento server needs to run?

The full list of software is listed in System Requirements but here are the essentials:

  • Web server to display web pages. Currently, we’ve documented Apache and plan to document other web servers in the near future.

  • Database management system for long-term data storage and retrieval. We support MySQL.

  • PHP, an acronym for PHP: Hypertext Preprocessor, an open source scripting language suited for web development because it can be embedded in HTML (the language of the web).

    For more information, see the PHP manual or the Wikipedia page.

If you use a hosting provider, they might already have installed this software. Contact them if you're not sure.