Upgrades and Patches

We use Composer for upgrades and patches to Magento Commerce (Cloud) and recommend running the composer update command.

Magento Commerce (Cloud) checks for pending patches and updates when you push code changes to the remote environment. The upgrade instructions walk through preparing, updating, and verifying the upgrade.

Prerequisite—Before beginning the upgrade process, create a new, active branch from Integration and checkout to your local workstation. Dedicating a branch to the upgrade process helps to avoid interference with work in progress.

PCI compliance requires TLS protocol version 1.2 or later. On April 30, 2018, all Magento Cloud instances must convert to using TLS version 1.2 or later.

Upgrade your Magento Commerce (Cloud) application architecture

We combined the upgrade metapackages for tools and patches with the release of ece-tools version 2002.0.8, which helps to provide an easier process for future updates. You need to upgrade to the new metapackage to use this process.

Some restrictions in the core Magento Commerce code base prevent you from upgrading to the new application architecture directly, so use the following table to determine your upgrade path:

Current Version Upgrade Path
2.1.3 and earlier You must upgrade to version 2.1.4 or later before you continue.
2.1.4 and later You can begin the upgrade to ece-tools 2002.0.9 and later.
2.2.x You can begin the upgrade to ece-tools 2002.0.8 and later.

Update the Magento Commerce (Cloud) metapackage

We are deprecating the magento/magento-cloud-configuration and magento/ece-patches packages.

You must perform a one-time, manual step to update the package version constraint for magento/magento-cloud-metapackage in the composer.json file, located in the root directory. This constraint enables updates for Magento Cloud metapackages—including removing deprecated packages—without upgrading your current Magento Commerce version.

Each Magento Commerce version requires a different constraint based on the following:

>=current_version <next_version

You can always find the latest metapackage constraint in the magento-cloud template.

The following example places a constraint for the Magento Cloud metapackage to any version greater than or equal to the current version 2.2.0 and lower than next version 2.2.1:

"require": {
    "magento/magento-cloud-metapackage": ">=2.2.0 <2.2.1"