Upgrade from CE to EE

Overview of Magento Community Edition (CE) to Magento Enterprise Edition (EE) upgrade

This section discusses how to upgrade Magento CE to Magento EE.

You must be authorized for Magento EE to perform the tasks discussed in this topic.

Prerequisites

Before continuing, complete all tasks discussed in Prerequisites.

In addition, you might need to install the PHP bcmath extension, which is required by EE. Examples follow:

  • CentOS (using the webtatic repository): yum -y install php56w-bcmath
  • Ubuntu (using the ppa:ondrej/php5-5.6 repository): apt-get -y install php5-bcmath

Make sure you are authorized for Magento EE access before you continue. Contact Magento Support if you have questions.

Start System Upgrade from the Magento Admin

To run System Upgrade:

  1. Log in to the Magento Admin as an administrator.
  2. Click System > Web Setup Wizard. The following page displays.

    Specify whether to manage components or upgrade Magento
  3. Click System Upgrade.

    Magento begins searching for core module updates immediately. To also search for component updates, click Yes. A sample follows:

    Magento begins searching for upgrades right away

    The page displays similar to the following when we find components to upgrade.

    Magento finds software to upgrade

    From the list, click the version to which to upgrade. Typically, you’ll choose the most recent version (indicated by (latest).)

After the upgrade completes, restart Varnish if you use it for page caching.

service varnish restart

Errors

  • The following error can indicate one of several issues, including that you haven’t entered your authentication keys in the Magento Admin:

    For suggested solutions to other causes indicated by this message, see troubleshooting.

  • The following error might display:

    [2016-01-19 23:33:24 UTC] An error occurred while executing job 
    "setup:upgrade {"command":"setup:upgrade"}": Could not complete 
    setup:upgrade {"command":"setup:upgrade"} successfully: Source 
    class "\Cybersource" for "CybersourceLogger" generation does not exist.
    

    For more information, see Error upgrading from CE to EE.

Continue your upgrade

From here, your upgrade is the same as any other upgrade. Continue with Step 1. Select versions to upgrade.