Magento_Sales module dependencies

The following is a code of module’s composer.json showing dependencies with Magento modules and metadata.

{
    "name": "magento/module-sales",
    "description": "N/A",
    "require": {
        "php": "~5.6.5|7.0.2|7.0.4|~7.0.6",
        "magento/module-store": "100.1.*",
        "magento/module-catalog": "101.0.*",
        "magento/module-customer": "100.1.*",
        "magento/module-authorization": "100.1.*",
        "magento/module-payment": "100.1.*",
        "magento/module-checkout": "100.1.*",
        "magento/module-theme": "100.1.*",
        "magento/module-sales-rule": "100.1.*",
        "magento/module-sales-sequence": "100.1.*",
        "magento/module-backend": "100.1.*",
        "magento/module-widget": "100.1.*",
        "magento/module-directory": "100.1.*",
        "magento/module-eav": "100.1.*",
        "magento/module-tax": "100.1.*",
        "magento/module-gift-message": "100.1.*",
        "magento/module-reports": "100.1.*",
        "magento/module-catalog-inventory": "100.1.*",
        "magento/module-wishlist": "100.1.*",
        "magento/module-shipping": "100.1.*",
        "magento/module-config": "100.1.*",
        "magento/module-media-storage": "100.1.*",
        "magento/framework": "100.1.*",
        "magento/module-ui": "100.1.*",
        "magento/module-quote": "100.1.*"
    },
    "suggest": {
        "magento/module-sales-sample-data": "Sample Data version:100.1.*"
    },
    "type": "magento2-module",
    "version": "100.1.5",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "autoload": {
        "files": [
            "registration.php"
        ],
        "psr-4": {
            "Magento\\Sales\\": ""
        }
    }
}