Magento 2.0.18 is the final 2.0.x release. After March 2018, Magento 2.0.x will no longer receive security patches, quality fixes, or documentation updates.
To maintain your site's performance, security, and PCI compliance, upgrade to the latest version of Magento.

Update the Functional Testing Framework

Two types of updates are available.

Use this type of update if the version of the Functional Testing Framework in <magento2>/dev/tests/functional/composer.json and last version in <magento2>/dev/tests/functional/vendor/magento/mtf/CHANGELOG.md are different. For example, when you updated Magento.

Use this type of update if you want to update dependent software from composer.json, or changed composer.json dependencies.

Install a new version of the Functional Testing Framework

Step 1. To avoid conflicts with the previous version, remove directory <magento2_root_dir>/dev/tests/functional/generate.

Step 2. Remove file <magento2_root_dir>/dev/tests/functional/composer.lock.

Why: Composer reads dependencies from composer.lock instead of reading composer.json. File composer.lock currently is not maintained.

Step 3. Perform and check installation.

Update components from dependencies in composer.json

Enter in terminal:

cd <magento2_root_dir>/dev/tests/functional/
composer update