PHP 7.3 reaches end of support in December 2021 and Adobe Commerce 2.3.x reaches end of support in April 2022. You may want to consider planning your upgrade now to Adobe Commerce 2.4.x and PHP 7.4.x to help maintain PCI compliance.

Update the updater application

In some cases, you might need to update the updater application, which is responsible for updating components and the Magento application. You should do this only if instructed to do so.

To update the updater application:

  1. Log in to your Magento server as, or switch to, the file system owner.
  2. Delete, move, or rename the directory containing the updater application.

    1
    
    mv <magento_root>/update <magento_root>/old_update
    
  3. Change to your Magento 2 installation directory and enter the following command:

    1
    
    composer create-project magento/updater update --repository https://repo.magento.com
    
  4. If prompted, enter your Magento authentication keys.
  5. Wait while Composer installs the updater and its dependencies.