PHP 7.3 reaches end of support in December 2021 and Adobe Commerce 2.3.x reaches end of support in April 2022. We strongly recommend planning your upgrade now to Adobe Commerce 2.4.x and PHP 7.4.x to help maintain PCI compliance.

Component development

Magento 2 is flexible and as a result has varied functionality, so developing a component in Magento takes into account a number of different of the following topics. Please read the information on compatibility — Service Contracts, Design Patterns, and the information on Dependency Injection, Routing, and Working With Public Interfaces and APIs closely; they are essential to creating a good Magento 2 component.