PHP 7.3 reaches end of support in December 2021 and Adobe Commerce 2.3.x reaches end of support in April 2022. You may want to consider planning your upgrade now to Adobe Commerce 2.4.x and PHP 7.4.x to help maintain PCI compliance.

Validate

After your module is built, you need to test it. Read through the Definition of Done to confirm that your module and coding practice is compliant with Magento.