PHP 7.3 reaches end of support in December 2021 and Adobe Commerce 2.3.x reaches end of support in April 2022. You may want to consider planning your upgrade now to Adobe Commerce 2.4.x and PHP 7.4.x to help maintain PCI compliance.

Check the Commerce version

Use any of the following ways to determine which version of Magento is installed:

  • From the command line
  • With an HTTP GET request
  • From within the Admin
  • By viewing the composer.lock file

Command line

The following command returns the Magento version.

Command:

1
bin/magento --version

Response:

1
Magento CLI version 2.3.0

HTTP GET request

An HTTP request returns less detailed information about the Magento version.

Request:

1
http://<magento2-store>/magento_version

Response:

1
Magento/2.3 (Community)

Admin

Login to Magento as a registered Admin user. The Magento version is displayed at the bottom right of the page, above the Account Activity and Report an Issue links:

Check the Magento version

The composer.lock file

If Magento was installed using the composer install command, you can search the <Magento_root>/composer.lock file for magento/product-community-edition or magento/product-enterprise-edition, depending on which version of Magento is installed.

1
2
3
  {
    "name": "magento/product-community-edition",
    "version": "2.3.2",