PHP 7.3 reaches end of support in December 2021 and Adobe Commerce 2.3.x reaches end of support in April 2022. You may want to consider planning your upgrade now to Adobe Commerce 2.4.x and PHP 7.4.x to help maintain PCI compliance.

Reinstall the Magento software

A contributing developer reinstalls Magento by updating composer.json to specify the Magento product version and component versions desired and runs composer update.

To reinstall the Magento software as a contributing developer:

  1. Log in to your Magento server as a user with permissions to modify files in the Magento file system (for example, the switch to the file system owner.
  2. Make a backup copy of composer.json in your Magento installation directory:

    1
    
    cd <magento_root>
    
    1
    
    cp composer.json composer.json.bak
    
  3. Open composer.json in a text editor.
  4. Locate the following line:

    1
    2
    3
    
    "require": {
          "magento/product-community-edition": "<version>"
    },
    
  5. Replace <version> with the version to which you want to upgrade, where <version> is the product version to use.

    (The product version is in the format 2.0.x)

.

  1. Save your changes to composer.json and exit the text editor.
  2. Enter the following command:

    1
    
    composer update
    

    Wait for dependencies to update.

  3. Install the Magento software.