PHP 7.3 reaches end of support in December 2021 and Adobe Commerce 2.3.x reaches end of support in April 2022. We strongly recommend planning your upgrade now to Adobe Commerce 2.4.x and PHP 7.4.x to help maintain PCI compliance.

Magento_NegotiableQuoteSharedCatalog

Overview

The Magento_NegotiableQuoteSharedCatalog module enables the NegotiableQuote module to interact with a SharedCatalog in an B2B environment. This module extends the Magento_NegotiableQuote module and Magento_SharedCatalog modules.

The Magento_NegotiableQuoteSharedCatalog module provides the following features:

  • Remove items from a negotiable quote if corresponding products were removed from this company‚Äôs shared catalog.

Installation details

This module has a dependency on the Magento_NegotiableQuote and Magento_SharedCatalog module, which must be installed and enabled first.

The Magento_NegotiableQuoteSharedCatalog module does not create any backward incompatible changes. It can be uninstalled at any time.

Structure

Learn about a typical file structure for a Magento 2 module.

Extensibility

Extension developers can interact with the Magento_NegotiableQuoteSharedCatalog module. For more information about the Magento extension mechanism, see Magento plug-ins.

The Magento dependency injection mechanism enables you to override the functionality of the Magento_NegotiableQuoteSharedCatalog module.

Additional information

You can track backward incompatible changes made in a Magento B2b mainline after the Magento 2.3 release.