PHP 7.3 reaches end of support in December 2021 and Adobe Commerce 2.3.x reaches end of support in April 2022. You may want to consider planning your upgrade now to Adobe Commerce 2.4.x and PHP 7.4.x to help maintain PCI compliance.

Magento_AuthorizenetCardinal

Use the Magento_AuthorizenetCardinal module to enable 3D Secure 2.0 support for AuthorizenetAcceptjs payment integrations.

Structure

Gateway/ - the directory that contains payment gateway command interfaces and service classes.

For information about typical file structure of a module in Magento 2, see Module file structure.

Extensibility

Extension developers can interact with the Magento_AuthorizenetCardinal module. For more information about the Magento extension mechanism, see Magento plug-ins.

The Magento dependency injection mechanism enables you to override the functionality of the Magento_AuthorizenetCardinal module.

Events

This module observes the following events:

  • payment_method_assign_data_authorizenet_acceptjs event in the Magento\AuthorizenetCardinal\Observer\DataAssignObserver file.

For information about an event in Magento 2, see Events and observers.