PHP 7.3 reaches end of support in December 2021 and Adobe Commerce 2.3.x reaches end of support in April 2022. We strongly recommend planning your upgrade now to Adobe Commerce 2.4.x and PHP 7.4.x to help maintain PCI compliance.

Magento_RequireJs

Purpose of module

The Magento\RequireJs module introduces support for RequireJs JavaScript library and provides infrastructure for other modules to have them declared related configuration for RequireJs library.

Deployment

System requirements

The Magento\RequireJs module does not have any specific system requirements.

Install

The Magento\RequireJs module is installed automatically (using the native Magento Setup). No additional actions required.