PHP 7.3 reaches end of support in December 2021 and Adobe Commerce 2.3.x reaches end of support in April 2022. We strongly recommend planning your upgrade now to Adobe Commerce 2.4.x and PHP 7.4.x to help maintain PCI compliance.

Magento_AdminGwsConfigurableProduct

Magento_AdminGwsConfigurableProduct module

Overview

The Magento_AdminGwsConfigurableProduct module is a part of the restricted admin user permissions functionality in Magento EE. It extends the Magento_AdminGws module functionality for configurable product.

Implementation Details

The Magento_AdminGwsConfigurableProduct module:

  • adds plugin on \Magento\Magento_AdminGwsConfigurableProduct\Plugin\PermissionsDataChecker to check permissions for current user.

Dependencies

You can find the list of modules the Magento_AdminGwsConfigurableProduct module depends on in the require section of the composer.json file located in the same directory as this README.md file.

Extension Points

The Magento_AdminGwsConfigurableProduct module does not provide any specific extension points.

Additional information

For more Magento 2 developer documentation, see Magento 2 Developer Documentation.