This page has moved and will be redirected soon. See Migrated topics for the complete list.
You must install Elasticsearch or OpenSearch before installing Adobe Commerce or Magento Open Source 2.4.0. See Search engine prerequisites for details.

System requirements

This table shows versions of third-party software dependencies that Adobe has tested with specific Adobe Commerce and Magento Open Source releases. Adobe only supports the combination of system requirements described in the following table.

For example, 2.4.3 is fully tested with MariaDB 10.4. Adobe recommends that you upgrade to MariaDB 10.4 before upgrading to 2.4.3.

Software dependencies 2.4.5-p1 2.4.5 2.4.4-p2 2.4.4-p1 2.4.4 2.4.3-p3 2.4.3-p2 2.4.3 2.4.2 2.4.1 2.4.0
Composer 2.2 2.2 2.1 2.1 2.1 1 1 1 1.9, 2.0 1 1
Elasticsearch 7.17 7.17 7.16 7.16 7.16 7.16 7.16 7.10 7.9 7.7 7.6
OpenSearch 1.2 1.2 1.2 1.2 1.2 1.2 1.2 -- -- -- --
MariaDB 10.4 10.4 10.4 10.4 10.4 10.4 10.4 10.4 10.4 10.4 10.2, 10.3, 10.4
MySQL 8.0 8.0 8.0 8.0 8.0 8.0 8.0 8.0 8.0 8.0 5.7, 8.0
PHP 8.1 8.1 8.1 8.1 8.1 7.4 7.4 7.4 7.4 7.4 7.3, 7.4
RabbitMQ 3.9 3.9 3.9 3.9 3.9 3.8 3.8 3.8 3.8 3.8 3.8
Redis 6.2 6.2 6.2 6.2 6.2 6.0 6.0 6.0 6.0 5.0 5.0
Varnish 7.0 7.0 7.0 7.0 7.0 6.5 6.5 6.5 6.4 6.2 6
Apache 2.4 2.4 2.4 2.4 2.4 2.4 2.4 2.4 2.4 2.4 2.4
nginx 1.18 1.18 1.18 1.18 1.18 1.18 1.18 1.18 1.18 1.18 1.18
AWS Aurora (MySQL) 8.0 8.0 5.7 5.7 5.7 5.7 5.7 5.7 -- -- --
AWS S3 ✔️ ✔️ ✔️ ✔️ ✔️ ✔️ ✔️ ✔️ ✔️ -- --
AWS MQ 3.9.13 3.9.13 3.8.11 3.8.11 3.8.11 3.8.11 3.8.11 3.8.11 -- -- --
AWS ElastiCache Redis 6 Redis 6 Redis 6 Redis 6 Redis 6 Redis 6 Redis 6 Redis 6 -- -- --
AWS Elasticsearch 7.9 7.9 7.9 7.9 7.9 7.9 7.9 7.9 -- -- --
AWS OpenSearch 1.2 1.2 -- -- -- -- -- -- -- -- --

Adobe Commerce on cloud infrastructure

Service version and compatibility support for Adobe Commerce on cloud infrastructure is determined by versions deployed on the Cloud infrastructure, and sometimes differ from versions supported by Adobe Commerce on-premises deployments. For details on supported software and services deployed on Adobe Commerce on cloud infrastructure, see Supported software and services.

Miscellaneous

This section describes support and compatibility for all other types of required and optional software.

All of the following requirements apply to the latest patch release of Magento 2.4.

Mail server

Mail Transfer Agent (MTA) or Simple Mail Transfer Protocol (SMTP) server

Operating systems (Linux x86-64)

Linux distributions, such as RedHat Enterprise Linux (RHEL), CentOS, Ubuntu, Debian, and similar. Magento is not supported on Microsoft Windows and Apple macOS.

PHP extensions

The PHP installation instructions include a step for installing these extensions.

Magento Open Source and Adobe Commerce:

  • ext-bcmath
  • ext-ctype
  • ext-curl
  • ext-dom
  • ext-fileinfo
  • ext-gd
  • ext-hash
  • ext-iconv
  • ext-intl
  • ext-json
  • ext-libxml
  • ext-mbstring
  • ext-openssl
  • ext-pcre
  • ext-pdo_mysql
  • ext-simplexml
  • ext-soap
  • ext-sockets
  • ext-sodium
  • ext-tokenizer
  • ext-xmlwriter
  • ext-xsl
  • ext-zip
  • lib-libxml
  • lib-openssl

Additionally Adobe Commerce requires:

  • ext-bcmath
  • ext-ctype
  • ext-curl
  • ext-dom
  • ext-fileinfo
  • ext-gd
  • ext-hash
  • ext-iconv
  • ext-intl
  • ext-json
  • ext-libxml
  • ext-mbstring
  • ext-openssl
  • ext-pcre
  • ext-pdo_mysql
  • ext-simplexml
  • ext-soap
  • ext-sockets
  • ext-sodium
  • ext-spl
  • ext-tokenizer
  • ext-xmlwriter
  • ext-xsl
  • ext-zip
  • lib-libxml
  • lib-openssl

Refer to official PHP documentation for installation details.

PHP OPcache

We strongly recommend you verify that PHP OPcache is enabled for performance reasons. The OPcache is enabled in many PHP distributions. To verify if it is installed, see our PHP documentation.

If you must install it separately, see the PHP OPcache documentation.

PHP settings

We recommend particular PHP configuration settings, such as memory_limit, that can avoid common problems when using Magento.

For more information, see Required PHP settings.

PHPUnit

PHPUnit (as a command-line tool) 9.0.0

RAM

Upgrading the Magento applications and extensions you obtain from Commerce Marketplaces and other sources can require up to 2 GB of RAM. If you are using a system with less than 2 GB of RAM, Adobe recommends you create a swap file; otherwise, your upgrade might fail.

System dependencies

Magento requires the following system tools for some of its operations:

SSL

  • A valid security certificate is required for HTTPS.
  • Self-signed SSL certificates are not supported.
  • Transport Layer Security (TLS) requirement - PayPal and repo.magento.com both require TLS 1.2 or later.

Supported browsers

Storefront and Admin:

  • Microsoft Edge, latest and previous major version
  • Firefox latest, latest and previous major version (any operating system)
  • Chrome latest, latest and previous major version (any operating system)
  • Safari latest, latest and previous major version (Mac OS only)
  • Safari Mobile for iPad 2, iPad Mini, iPad with Retina Display (iOS 12 or later), for desktop storefront
  • Safari Mobile for iPhone 6 or later; iOS 12 or later, for mobile storefront
  • Chrome for mobile, latest and previous major version (Android 4 or later) for mobile storefront

Xdebug

php_xdebug 2.5.x or later (development environments only; can have an adverse effect on performance)

There is a known issue with xdebug that can affect Magento installations or access to the storefront or Admin after installation. For details, see Known issue with xdebug.