Adobe Commerce 2.4.2-p2 Release Notes

Adobe Commerce 2.4.2-p2 is a security release that provides 18 security fixes that enhance your Magento 2.4.2 deployment. Merchants can now install time-sensitive security fixes without applying the hundreds of functional fixes and enhancements that a full quarterly release provides. Patch 2.4.2-p2 provides fixes for vulnerabilities that have been identified in our previous quarterly release, Adobe Commerce 2.4.2 and Magento Open Source 2.4.2.

Apply AC-3022.patch to continue offering DHL as a shipping carrier

DHL has introduced schema version 6.2 and will deprecate schema version 6.0 in the near future. Adobe Commerce 2.4.4 and earlier versions that support the DHL integration support only version 6.0. Merchants deploying these releases should apply AC-3022.patch at their earliest convenience to continue offering DHL as a shipping carrier. See the Apply a patch to continue offering DHL as shipping carrier Knowledge Base article for information about downloading and installing the patch.

What’s in this release?

Eighteen security fixes are included in this security patch. See Adobe Security Bulletin.

Security patches typically include all hotfixes that have been released for the preceding complete release. However, no hot fixes have been released for Adobe Commerce 2.4.2 and Magento Open Source 2.4.2.

Installation and upgrade instructions

For instructions on downloading and applying security patches (including patch 2.4.2-p2), see Quick start install.

More information?

For general information about security patches, see Introducing the New Security Patch Release.