Adobe Commerce 2.4.3-p1 Release Notes

Adobe Commerce 2.4.3-p1 is a security release that provides seven security fixes that enhance your Adobe Commerce 2.4.3 or Magento Open Source 2.4.3 deployment. It provides fixes for vulnerabilities that have been identified in the previous release (Adobe Commerce 2.4.3 and Magento Open Source 2.4.3).

Releases may contain backward-incompatible changes (BIC). To review minor backward-incompatible changes, see BIC reference. (Major backward-incompatible issues are described in BIC highlights. Not all releases introduce major BICs.)

What’s in this release?

This security patch includes:

  • All hotfixes that have been released for the preceding patch release
  • Security enhancements
  • Seven security bug fixes. Only one of these seven fixes is an externally reported vulnerability. Fixes for externally reported vulnerabilities are documented in the Adobe Security Bulletin.
  • Bug fixes for the Braintree, Klarna, and Vertex vendor-developed extensions.

Hotfixes

This release includes the following hotfix:

Security highlights

Session IDs have been removed from the database. This code change may result in breaking changes if merchants have customizations or installed extensions that use the raw session IDs stored in the database.

Restricted admin access to Media Gallery folders. Default Media Gallery permissions now allow only directory operations (view, upload, delete, and create) that are explicitly allowed by configuration. Admin users can no longer access media assets through the Media Gallery that were uploaded outside of the catalog/category or wysiwyg directories. Administrators who want to access media assets must move them to an explicitly allowed folder or adjust their configuration settings. See Modify Media Library folder permissions.

Lowered limits to GraphQL query complexity. The GraphQL maximum allowed query complexity has been lowered to prevent Denial-of-Service (DOS) attacks. See GraphQL security configuration.

Recent penetration test vulnerabilities have been fixed in this release.

The unsupported source expression unsafe-inline has been removed from the Content Security Policy frame-ancestors directive. GitHub-33101

Installation and upgrade instructions

For instructions on downloading and applying security patches (including patch 2.4.3-p1), see Quick start install.

More information?

For general information about security patches, see Introducing the New Security Patch Release.